MPLS LDP Based VPLS Mikrotik Lab


In this scenario the customer need to connect each site with one segment IP address as shown in the diagram. We will configuring labeling using LDP and using VPLS as tunneling between each site. Considering that you already configuring IP Address, Loopback and OSPF properly. Take a not that interface of R1 and R2 facing to customer is not assign IP Address.

By enabling MPLS forwarding can speed up packet forwarding process in such network. Using one of MPLS applications. VPLS can further increase efficency of ethernet frame forwarding by not having to encapsulate ethernet frames in IP frames, thus removing IP header overhead.

LDP Configuration on Provider Router
Internet Router
/mpls ldp
set enabled=yes lsr-id=10.10.10.10 transport-address=10.10.10.10

/mpls ldp interface
add interface=ether1
add interface=ether2

PublicNet1
/mpls ldp
set enabled=yes lsr-id=8.8.8.8 transport-address=8.8.8.8

/mpls ldp interface
add interface=ether1
add interface=ether2
add interface=ether3

PublicNet2
/mpls ldp
set enabled=yes lsr-id=8.8.4.4 transport-address=8.8.4.4

/mpls ldp interface
add interface=ether1
add interface=ether2
add interface=ether3

R1
/mpls ldp
set enabled=yes lsr-id=1.1.1.1 transport-address=1.1.1.1

/mpls ldp interface
add interface=ether1

R2
/mpls ldp
set enabled=yes lsr-id=2.2.2.2 transport-address=2.2.2.2

/mpls ldp interface
add interface=ether1

LDP Verification on Internet Router, you can try same command on another router.
[admin@Internet] > mpls ldp neighbor print
Flags: X - disabled, D - dynamic, O - operational, T - sending-targeted-hello, V - vpls
 #      TRANSPORT       LOCAL-TRANSPORT PEER                       SEND-TARGETED ADDRESSES
 0 DO   8.8.4.4         10.10.10.10     8.8.4.4:0                  no            8.8.4.4
                                                                                 10.10.2.2
                                                                                 10.10.3.2
                                                                                 23.23.23.1
 1 DO   8.8.8.8         10.10.10.10     8.8.8.8:0                  no            8.8.8.8
                                                                                 10.10.1.2
                                                                                 10.10.3.1
                                                                                 12.12.12.1

[admin@Internet] > mpls remote-bindings print
Flags: X - disabled, A - active, D - dynamic
 #    DST-ADDRESS        NEXTHOP         LABEL                                     PEER
 0  D 10.10.1.0/30                       16                                        8.8.4.4:0
 1 AD 23.23.23.0/30      10.10.2.2       impl-null                                 8.8.4.4:0
 2 AD 10.10.3.0/30       10.10.2.2       impl-null                                 8.8.4.4:0
 3  D 10.10.10.10/32                     17                                        8.8.4.4:0
 4 AD 8.8.4.4/32         10.10.2.2       impl-null                                 8.8.4.4:0
 5  D 10.10.2.0/30                       impl-null                                 8.8.4.4:0
 6  D 8.8.8.8/32                         18                                        8.8.4.4:0
 7  D 12.12.12.0/30                      19                                        8.8.4.4:0
 8  D 10.10.3.0/30                       impl-null                                 8.8.8.8:0
 9 AD 8.8.8.8/32         10.10.1.2       impl-null                                 8.8.8.8:0
10  D 10.10.1.0/30                       impl-null                                 8.8.8.8:0
11  D 23.23.23.0/30                      16                                        8.8.8.8:0
12 AD 1.1.1.1/32         10.10.1.2       17                                        8.8.8.8:0
13 AD 12.12.12.0/30      10.10.1.2       impl-null                                 8.8.8.8:0
14  D 10.10.10.10/32                     18                                        8.8.8.8:0
15  D 8.8.4.4/32                         19                                        8.8.8.8:0
16  D 10.10.2.0/30                       20                                        8.8.8.8:0
17  D 2.2.2.2/32                         21                                        8.8.8.8:0
18  D 1.1.1.1/32                         20                                        8.8.4.4:0
19 AD 2.2.2.2/32         10.10.2.2       21                                        8.8.4.4:0

[admin@Internet] > mpls forwarding-table print
Flags: L - ldp, V - vpls, T - traffic-eng
 #   IN-LABEL             OUT-LABELS         DESTINATION                    INTERFACE         NEXTHOP
 0   expl-null
 1 L 16                                      12.12.12.0/30                  ether1            10.10.1.2
 2 L 17                                      8.8.8.8/32                     ether1            10.10.1.2
 3 L 18                                      23.23.23.0/30                  ether2            10.10.2.2
 4 L 19                   17                 1.1.1.1/32                     ether1            10.10.1.2
 5 L 20                                      10.10.3.0/30                   ether2            10.10.2.2
 6 L 21                                      8.8.4.4/32                     ether2            10.10.2.2
 7 L 22                   21                 2.2.2.2/32                     ether2            10.10.2.2

[admin@Internet] > mpls local-bindings print
Flags: X - disabled, A - advertised, D - dynamic, L - local-route, G - gateway-route, e - egress
 #      DST-ADDRESS        LABEL                                                   PEERS
 0 ADG  12.12.12.0/30      16                                                      8.8.4.4:0
                                                                                   8.8.8.8:0
 1 ADG  8.8.8.8/32         17                                                      8.8.4.4:0
                                                                                   8.8.8.8:0
 2 ADLe 10.10.1.0/30       impl-null                                               8.8.4.4:0
                                                                                   8.8.8.8:0
 3 ADG  23.23.23.0/30      18                                                      8.8.4.4:0
                                                                                   8.8.8.8:0
 4 ADG  1.1.1.1/32         19                                                      8.8.4.4:0
                                                                                   8.8.8.8:0
 5 ADG  10.10.3.0/30       20                                                      8.8.4.4:0
                                                                                   8.8.8.8:0
 6 ADLe 10.10.10.10/32     impl-null                                               8.8.4.4:0
                                                                                   8.8.8.8:0
 7 ADG  8.8.4.4/32         21                                                      8.8.4.4:0
                                                                                   8.8.8.8:0
 8 ADLe 10.10.2.0/30       impl-null                                               8.8.4.4:0
                                                                                   8.8.8.8:0
 9 ADG  2.2.2.2/32         22                                                      8.8.8.8:0
                                                                                   8.8.4.4:0

Test tracert from R1 to R2
[admin@R1] > tool traceroute src-address=1.1.1.1 2.2.2.2
 # ADDRESS    LOSS SENT    LAST     AVG    BEST   WORST STD-DEV STATUS
 1 12.12.12.1 0%    4   2.5ms     4.2     1.8    10.7     3.7 <MPLS:L=21,E=0>
 2 10.10.3.2  0%    4   1.8ms     1.9     1.8     2.1     0.1 <MPLS:L=21,E=0>
 3 2.2.2.2    0%    4   1.6ms     1.6     1.5     1.8     0.1
See on status there is labeled with MPLS

VPLS Configuration on Provider Edge Router
R1
/interface bridge
add name=br-Customer-A

/interface vpls
add disabled=no l2mtu=1500 mac-address=02:A7:92:46:33:B7 name=VPLS-Customer-A remote-peer=2.2.2.2 vpls-id=1:1

/interface bridge port
add bridge=br-Customer-A interface=ether2
add bridge=br-Customer-A interface=VPLS-Customer-A

Verification VPLS
[admin@R1] > int pr
Flags: D - dynamic, X - disabled, R - running, S - slave
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU MAC-ADDRESS
 0  R  ether1                              ether            1500                  00:61:94:E4:D4:00
 1  RS ether2                              ether            1500                  00:61:94:E4:D4:01
 2  R  ether3                              ether            1500                  00:61:94:E4:D4:02
 3  R  ether4                              ether            1500                  00:61:94:E4:D4:03
 4  R  ether5                              ether            1500                  00:61:94:E4:D4:04
 5  RS VPLS-Customer-A                     vpls             1500  1500            02:A7:92:46:33:B7
 6  R  br-Customer-A                       bridge           1500  1500            00:61:94:E4:D4:01
 7  R  lo1                                 bridge           1500 65535            00:00:00:00:00:00

R2
/interface bridge
add name=br-Customer-A

/interface vpls
add disabled=no l2mtu=1500 mac-address=02:6F:ED:92:AD:57 name=VPLS-Customer-A remote-peer=1.1.1.1 vpls-id=1:1

/interface bridge port
add bridge=br-Customer-A interface=ether2
add bridge=br-Customer-A interface=VPLS-Customer-A

Verification VPLS
[admin@R2] > int pr
Flags: D - dynamic, X - disabled, R - running, S - slave
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU MAC-ADDRESS
 0  R  ether1                              ether            1500                  00:61:94:05:95:00
 1  RS ether2                              ether            1500                  00:61:94:05:95:01
 2  R  ether3                              ether            1500                  00:61:94:05:95:02
 3  R  ether4                              ether            1500                  00:61:94:05:95:03
 4  R  ether5                              ether            1500                  00:61:94:05:95:04
 5  RS VPLS-Customer-A                     vpls             1500  1500            02:6F:ED:92:AD:57
 6  R  br-Customer-A                       bridge           1500  1500            00:61:94:05:95:01
 7  R  lo1                                 bridge           1500 65535            00:00:00:00:00:00

Verification on CE or Customer Equipment
VPCS-1> ping 192.168.1.2
84 bytes from 192.168.1.2 icmp_seq=1 ttl=64 time=6.243 ms
84 bytes from 192.168.1.2 icmp_seq=2 ttl=64 time=2.855 ms
84 bytes from 192.168.1.2 icmp_seq=3 ttl=64 time=3.047 ms
84 bytes from 192.168.1.2 icmp_seq=4 ttl=64 time=2.896 ms
84 bytes from 192.168.1.2 icmp_seq=5 ttl=64 time=3.892 ms

VPCS> ping 192.168.1.1
84 bytes from 192.168.1.1 icmp_seq=1 ttl=64 time=3.732 ms
84 bytes from 192.168.1.1 icmp_seq=2 ttl=64 time=2.841 ms
84 bytes from 192.168.1.1 icmp_seq=3 ttl=64 time=2.877 ms
84 bytes from 192.168.1.1 icmp_seq=4 ttl=64 time=2.734 ms
84 bytes from 192.168.1.1 icmp_seq=5 ttl=64 time=4.978 ms